• <samp id="frm2q"><ins id="frm2q"></ins></samp>
      1. <samp id="frm2q"></samp>
        <progress id="frm2q"><bdo id="frm2q"><strong id="frm2q"></strong></bdo></progress>
        <menuitem id="frm2q"><ins id="frm2q"><u id="frm2q"></u></ins></menuitem>

        <progress id="frm2q"></progress>
      2. ionic莫名其妙的“cordova/platform_metadata”

        小編:管理員 153閱讀 2022.09.13

        我的Cordova升級到8已經很久了,而且在此環境下原有的項目跑得好好的,所以別人說有問題需要把Corodva降級到7.1或者7.0時,我不置可否。

        最近嫌nvm的node版本下的包(路徑:~/.nvm/versions/node)和原有node的包冗余,就手動清理了一下,當時也沒有發現什么問題,后來想打包到真機時報錯了,拋出如下錯誤:

        cordova/platform_metadata

        打。

        cordova -v
        復制

        顯示的是8.0.0,鑒于我原有項目在Cordova8下正常的,我便想是platform的問題,嘗試移除android平臺并重新添加:

        ionic cordova platform rm andoid
        ionic cordova platform add android@6.4.0
        復制

        結果無法移除自然也無法添加,那只好手動刪除文件和配置并重新嘗試,結果還是不行,這時網上流傳有兩種方法: 1、重新安裝cordova-plugin-add-swift-support插件; 2、把cordova降級;

        看了下package.json沒有cordova-plugin-add-swift-support插件,所以選用第二種方法:

        sudo npm uninstall cordova -g
        sudo npm install cordova@7.1.0 -g
        復制

        結果問題解決了!真的是這個原因?我又嘗試回滾到Cordova8來驗證:

        sudo npm uninstall cordova -g
        sudo npm install cordova -g
        ionic cordova platform rm android
        ionic cordova platform ls
        ionic cordova platform add android@6.4.0
        復制

        然后最后一步時,在安裝ionic-plugin-keyboard插件時報cordova/platform_metadata錯誤,那我把它移除再跑, 此時又在安裝cordova-plugin-whitelist時報同樣錯誤,那我再把它移除還報……然后我便懶得試了……

        關聯標簽:
        日本漂亮人妻被强制

      3. <samp id="frm2q"><ins id="frm2q"></ins></samp>
          1. <samp id="frm2q"></samp>
            <progress id="frm2q"><bdo id="frm2q"><strong id="frm2q"></strong></bdo></progress>
            <menuitem id="frm2q"><ins id="frm2q"><u id="frm2q"></u></ins></menuitem>

            <progress id="frm2q"></progress>